Jump to content
iMixx - legionm2.com

Help give_basic_weapon

Recommended Posts

Hola denuevo!

Tengo este problema con la quest de inicio, todo bien pero al cerrar el cuadro
se quedan las letras. Saben qué podrá ser?
Adjunto quest.

Gracias!

Debes iniciar sesión para ver el contenido del archivo adjunto en esta publicación.

Debes iniciar sesión para ver el contenido del enlace en esta publicación.

Share this post


Link to post
Share on other sites
hace 4 horas, iMixx - legionm2.com dijo:

Hola denuevo!

Tengo este problema con la quest de inicio, todo bien pero al cerrar el cuadro
se quedan las letras. Saben qué podrá ser?

Gracias!

Debes iniciar sesión para ver el contenido del archivo adjunto en esta publicación.

Como implementaste ese sistema lo tienes

Share this post


Link to post
Share on other sites

puedes postear aqui la quest de inicio o simplemente usar otra, asegurate de borrar bien esa quest, con el sh borrado_quest.sh e instala una nueva, a ver si el problema persiste o que pedo xd

Share this post


Link to post
Share on other sites
hace 1 hora, ReuS dijo:

puedes postear aqui la quest de inicio o simplemente usar otra, asegurate de borrar bien esa quest, con el sh borrado_quest.sh e instala una nueva, a ver si el problema persiste o que pedo xd

Depende que serverfiles use porque yo intente borrar una quest con ese borrado_quest.sh en las files martysama y no sirvio pero da igual si tiene mejor se borra solo con los comandos

Share this post


Link to post
Share on other sites

Enserio estoy leyendo quest de inicio gráficos, y que no borra en martysama?, 

No es mejor decir, no tengo ni puta idea de usar un script y hacer funcionar una quest básica, me ayudáis?. 

1-ese error seguramente es porque al modificarla se ha roto la cadena con la que está formada, la solución es instalar la original o probar otra y tener más cuidado al traducir. 

2-El script de borrado te lo recomiendo, funciona muy bien en todos los servefiles no hagas caso a que no funciona en marty. 

3-no es un sistema, es una quest y no tiene nada que ver con gráficas o ese fallo, por dios si es que al final me van a banear. 

Share this post


Link to post
Share on other sites
hace 17 minutos, NazoX dijo:

Enserio estoy leyendo quest de inicio gráficos, y que no borra en martysama?, 

No es mejor decir, no tengo ni puta idea de usar un script y hacer funcionar una quest básica, me ayudáis?. 

1-ese error seguramente es porque al modificarla se ha roto la cadena con la que está formada, la solución es instalar la original o probar otra y tener más cuidado al traducir. 

2-El script de borrado te lo recomiendo, funciona muy bien en todos los servefiles no hagas caso a que no funciona en marty. 

3-no es un sistema, es una quest y no tiene nada que ver con gráficas o ese fallo, por dios si es que al final me van a banear. 

Toda la razón del mundo tienes xDD.

Yo ya dije que al traducirla o al editarla se la habría cargado, cuando empieza a desvariar la cosa paso del tema.

Share this post


Link to post
Share on other sites

Buenas

Les dejo la quest.
(Ojo, que el usuario Kenshi Torres no es el mismo que yo)

Gracias!

Debes iniciar sesión para ver el contenido del enlace en esta publicación.

Share this post


Link to post
Share on other sites
hace 7 horas, NazoX dijo:

Enserio estoy leyendo quest de inicio gráficos, y que no borra en martysama?, 

No es mejor decir, no tengo ni puta idea de usar un script y hacer funcionar una quest básica, me ayudáis?. 

1-ese error seguramente es porque al modificarla se ha roto la cadena con la que está formada, la solución es instalar la original o probar otra y tener más cuidado al traducir. 

2-El script de borrado te lo recomiendo, funciona muy bien en todos los servefiles no hagas caso a que no funciona en marty. 

3-no es un sistema, es una quest y no tiene nada que ver con gráficas o ese fallo, por dios si es que al final me van a banear. 

Yo me referia las servefiles tiene unas quest de bienvenida que abre y te dice bienvenido te aparecen unas letras rojas y coji esa quest agrege alas de martysama y no aparecio los graficos rojos que suele aparecer

Share this post


Link to post
Share on other sites
hace 3 horas, iMixx - legionm2.com dijo:

Buenas

Les dejo la quest.
(Ojo, que el usuario Kenshi Torres no es el mismo que yo)

Gracias!

Debes iniciar sesión para ver el contenido del enlace en esta publicación.

No te entiendo a que te refieres 

Share this post


Link to post
Share on other sites
hace 6 horas, Kenshi Torres dijo:

Yo me referia las servefiles tiene unas quest de bienvenida que abre y te dice bienvenido te aparecen unas letras rojas y coji esa quest agrege alas de martysama y no aparecio los graficos rojos que suele aparecer

Eso es porque no tienes el scripts de colores, en las funciones para poder usar las letras de colores, sacalas de akron y ponlas en tu base y podrás usar letras de colores. 

Share this post


Link to post
Share on other sites
hace 6 horas, Kenshi Torres dijo:

Yo me referia las servefiles tiene unas quest de bienvenida que abre y te dice bienvenido te aparecen unas letras rojas y coji esa quest agrege alas de martysama y no aparecio los graficos rojos que suele aparecer

hace 21 minutos, NazoX dijo:

Eso es porque no tienes el scripts de colores, en las funciones para poder usar las letras de colores, sacalas de akron y ponlas en tu base y podrás usar letras de colores. 


Eso eso eso, fijate en los say de la quest que tienes y cambialos por los say de colores que tengan implementados en los files martysama. Esos los puedes encontrar en el archivo "quest_functions" en el directorio "quest" del ftp.

Share this post


Link to post
Share on other sites

Estuve revisando este caso con el autor

La quest no existía en la carpeta original, solo en la compilada (object)

Borré la carpeta object y luego compilé todas las quest

En este punto esa give_basic_weapon ya no existe.

Luego creamos un archivo con otro nombre, le pusimos un say para testear, y sucedió lo mismo...

Lo único que se me ocurre ahora sería borrar de nuevo la carpeta object, compilar una quest cualquiera con say en un when login. Esto con el objetivo de averiguar si otras quest entran en conflicto

Si sigue ocurriendo lo mismo ya es un bug desde otro lado

Share this post


Link to post
Share on other sites

Buenas, estaba buscando una quest de inicio y encontré esta xD la edité un poco pero al cargarla me sale el 'core dumped', no sé que habré dejado mal...

 

quest give_basic_weapon begin
	state start begin
		when login with pc.get_level() == 1 begin
			set_state(__COMPLETE__)
			local emp = { "Shinsoo" , "Chunjo" , "Jinno" }

			if pc.get_sex() == 0 then
				notice_all ( "Le damos la bienvenida a " .. pc . get_name ( ) .. " al Reino "..emp[pc.empire] .." !" ) 
			else
				notice_all ( "Le damos la bienvenida a " .. pc . get_name ( ) .. " al Reino "..emp[pc.empire] .." !" ) 
			end

			pc.change_gold ( 1000 )
			pc.give_item2 ( "27003" , 200 )
			pc.give_item2 ( "27006" , 200 )
			pc.give_item2 ( "71050" , 10 )
			pc.give_item2 ( "72702" , 1 )
			pc.give_item2 ( "50053" , 1 )

			if pc.job == 0 then 
				pc.give_item2 ( "19" , 1 )
				pc.give_item2 ( "3009" , 1 )
				pc.give_item2 ( "11209" , 1 )
				pc.give_item2 ( "50187" , 1 )
			elseif pc.job == 1 then
				pc.give_item2 ( "1009" , 1 )
				pc.give_item2 ( "2009" , 1 )
				pc.give_item2 ( "299" , 1 )
				pc.give_item2 ( "11409" , 1 )
				pc.give_item2 ( "50187" , 1 )
			elseif pc.job == 2 then
				pc.give_item2 ( "19" , 1 )
				pc.give_item2 ( "11609" , 1 )
				pc.give_item2 ( "50187" , 1 )
			elseif pc.job == 3 then
				pc.give_item2 ( "5009" , 1 )
				pc.give_item2 ( "7009" , 1 )
				pc.give_item2 ( "11809" , 1 )
				pc.give_item2 ( "50187" , 1 )
			elseif pc.job == 4 then
				pc.set_skill_group ( 1 )
				pc.clear_skill ( )
				char_log ( 0 , "CLEAR_SKILL" , " Se elimina la habilidad natural después de la maestria. " )
				if not pc.is_clear_skill_group ( ) then 
					pc.set_skill_level(170,20)
					pc.set_skill_level(171,20)
					pc.set_skill_level(172,20)
					pc.set_skill_level(173,20)
					pc.set_skill_level(174,20)
					pc.set_skill_level(175,20)
				end
			end
			
			horse.advance()
			horse.summon()
			horse.ride()
			end 
		end
	end
	state __COMPLETE__ begin
	end
end

 

Share this post


Link to post
Share on other sites
hace 4 minutos, iMixx - legionm2.com dijo:

Borra el elseif pc.job 4 completo si no tienes licano en tus files. 

El archivo está en extensión lua, al compilar fijate que lo escribas de esta manera. 

Ya eliminé el job 4

Al parecer toma error en la linea 58 que seria esta     state __COMPLETE__ begin

image.png

Share this post


Link to post
Share on other sites
hace 6 horas, caanmasu dijo:

image.png

 

Ese end lo debes borrar

 

Revisa el punto 2 en la parte de los bloques

Gracias

Debes iniciar sesión para ver el contenido del enlace en esta publicación.
 supuse que era por algún end, ahora solo me falta la funcion de STATE COMPLETE que la saco de algunos files que tenga por ahí e.e

Debes iniciar sesión para ver el contenido del archivo adjunto en esta publicación.

Share this post


Link to post
Share on other sites
En 26/7/2021 a las 6:10, 【ℛ-𝓝】ℛ𝔂𝓼𝒆 dijo:

Gracias

Debes iniciar sesión para ver el contenido del enlace en esta publicación.
 supuse que era por algún end, ahora solo me falta la funcion de STATE COMPLETE que la saco de algunos files que tenga por ahí e.e

Debes iniciar sesión para ver el contenido del archivo adjunto en esta publicación.

Te falta la función pc.set_skill_level no state complete... 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...