Jump to content
  • 0
Sign in to follow this  
halox

No conecta cliente al servidor

Question

Estoy usando freebsd12.1

Ya tengo todo instalado, server files, mysql files, mysql 8... librerias 32, 64, portsnap, etc.

Mi problema viene al iniciar el servidor, tengo en el cliente puesto la ip, y tanto en los files como en el cliente estan los mismos puertos pero me aparece todo el rato ERROR AL CONECTAR AL SERVIDOR.

Estoy usando los files de tunex(eternia2). Cuando hago un lsof -i -P -n | grep LISTEN, no me salen los puertos del metin escuchando. Supuestamente al iniciar el sh, ya automaticamente deberian abrirse no?

 

Debes iniciar sesión para ver el contenido del enlace en esta publicación.

Debes iniciar sesión para ver el contenido del enlace en esta publicación.

Debes iniciar sesión para ver el contenido del enlace en esta publicación.

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Los files eternia tienen un bug en el serverinfo, tienes que cambiarlo por este :

Quote

import app

app.ServerName = None

STATE_NONE = '...'
        
STATE_DICT = {
    0 : '....',
    1 : 'NORM',
    2 : 'BUSY',
    3 : 'FULL'    }

SERVER1_CHANNEL_DICT = {
    1:{'key':11,'name':'CH1   ','ip':'200.200.200.200','tcp_port':13031,'udp_port':13031,'state':STATE_NONE,},
    2:{'key':12,'name':'CH2   ','ip':'200.200.200.200','tcp_port':17031,'udp_port':17031,'state':STATE_NONE,},
    3:{'key':13,'name':'CH3   ','ip':'200.200.200.200','tcp_port':18031,'udp_port':18031,'state':STATE_NONE,},
    4:{'key':14,'name':'CH4   ','ip':'200.200.200.200','tcp_port':20031,'udp_port':20031,'state':STATE_NONE,},
}


SERVER2_CHANNEL_DICT = {
    1:{'key':21,'name':'CH1   ','ip':'200.200.200.200','tcp_port':13031,'udp_port':13031,'state':STATE_NONE,},
    2:{'key':22,'name':'CH2   ','ip':'200.200.200.200','tcp_port':17031,'udp_port':17031,'state':STATE_NONE,},
}

REGION_NAME_DICT = {
    0 : 'TAIWAN',
}

REGION_AUTH_SERVER_DICT = {
    0 : {
        1 : { 'ip':'200.200.200.200', 'port':11002, },
        2 : { 'ip':'200.200.200.200', 'port':11002, },
        
        }    
}

REGION_DICT = {
    0 : {
        1 : { 'name' : 'Metin2Zone', 'channel' : SERVER1_CHANNEL_DICT, },
        2 : { 'name' : 'Servidor de Pruebas', 'channel' : SERVER2_CHANNEL_DICT, },
        },
}

MARKADDR_DICT = {
    10 : { 'ip' : '200.200.200.200', 'tcp_port' : 13031, 'mark' : '10.tga', 'symbol_path' : '10', },
    20 : { 'ip' : '200.200.200.200', 'tcp_port' : 13031, 'mark' : '10.tga', 'symbol_path' : '10', },
    }

TESTADDR = { 'ip' : '200.200.200.200', 'tcp_port' : 50000, 'udp_port' : 50000, }

#DONE

#Break gracias a él

Y debería funcionar, no he encontrado tantos problemas para iniciar!

Share this post


Link to post
Share on other sites
  • 0
hace 3 horas, NazoX dijo:

Los files eternia tienen un bug en el serverinfo, tienes que cambiarlo por este :

#Break gracias a él

Y debería funcionar, no he encontrado tantos problemas para iniciar!

nada, ni con esas se conecta 

Share this post


Link to post
Share on other sites
  • 0
hace 1 minuto, halox dijo:

nada, ni con esas se conecta 

Lo dudo del eternia, pues como te comento nunca he encontrado ese problema nunca entenderé porque algunos no funcioan y otros sí, pero busca en config.cpp la ip 192.168

y cambialo por 999.999 compila y prueba, si no funciona, compila el .exe de nuevo y prueba y revisa que no falte ningún archivo como localeinfo, o algo así que tenga otra ip aunque lo dudo solo el problema era el serverinfo.

los Syssers del ch te dicen algo?

Share this post


Link to post
Share on other sites
  • 0
hace 4 minutos, NazoX dijo:

Lo dudo del eternia, pues como te comento nunca he encontrado ese problema nunca entenderé porque algunos no funcioan y otros sí, pero busca en config.cpp la ip 192.168

y cambialo por 999.999 compila y prueba, si no funciona, compila el .exe de nuevo y prueba y revisa que no falte ningún archivo como localeinfo, o algo así que tenga otra ip aunque lo dudo solo el problema era el serverinfo.

los Syssers del ch te dicen algo?

sysser en la carpeta del cliente no me dice nada está en blanco.

 

ahi ya me he perdido, config.cpp donde está? y como descompilo el .exe?

 

de todas maneras estos files ya los tuvimos hace 3 años, y funcionaban, ahora los hemos puesto de nuevo y no funciona, tambien es que la otra vez nos lo instalaron

Share this post


Link to post
Share on other sites
  • 0
hace 11 minutos, halox dijo:

sysser en la carpeta del cliente no me dice nada está en blanco.

 

ahi ya me he perdido, config.cpp donde está? y como descompilo el .exe?

 

de todas maneras estos files ya los tuvimos hace 3 años, y funcionaban, ahora los hemos puesto de nuevo y no funciona, tambien es que la otra vez nos lo instalaron

Pues vamos un poco mal si no sabes eso compañero xD!, 

Sysser del Canal no del cliente, de CH,  el config.cpp es source game y el .exe binario

Share this post


Link to post
Share on other sites
  • 0
hace 2 horas, ArkaNo96 dijo:

Revisa los logs de la base de datos si enciende la mysql:

Un saludo 

 

no hay ningun error

Share this post


Link to post
Share on other sites
  • 0
hace 2 horas, Alveiro Mantilla Moreno dijo:

cuales son los de tunex? eternia 2 o la editada por el?

 

Cuando los pasaron ponia tunex, y luego mirando vi que ponia eternia 2 en un archivo

Share this post


Link to post
Share on other sites
  • 0

Los eternia si no estoy mal aparte de server info tenia un error en los config de la db. Revisalos ya que creo que dicen Singapure y en es germany. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...