Jump to content

Recommended Posts

Hola, buenas.

Tengo un problema bastante grave. Resulta que uso files de maxmi 34k y el cliente de omega 34k. He de decir que me aseguraron que el cliente de omega en esos files funcionaban de maravilla y yo me lo creí. Pero ahora me he dado cuenta que cometí un error en creer esas palabras por que me está dando muchos problemas.

Me dejo de rodeos, el caso es el siguiente: hay algunos mapas bugueados o que no funcionan, creo. Resulta que haciendo uno de mis numerosos test, me di cuenta que si me teletransporto a mapas como "map_wedding", "Jungrang (zona de gremios)" o el mismo peñasco del dragón (este mapa nuevo del nivel 90), el juego me bota directamente y si me logueo de nuevo me vuelve a echar, sin la posibilidad de entrar al personaje.

Para ver donde rayos me envió, abrí el navicat y me di cuenta que el map_index ponia 800.000. Una ID ridícula. Para recuperar al PJ puse un 1 en el map_index y ya estaba (para dejarlo en city1). Pero claro, yo quiero solucionar esto.

 

Creo que el problema no está en el cliente, ya que he intentado copiar otros outdoor de otros clientes, sin ningún resultado. Quizás el problema radica totalmente en la diferencia de "cliente-servidor" (ya que uso el cliente de omega 34k en los files de maxmi 34k, quizás se produce algún error en la ID de los mapas, o mismo las IDs son distintas). Quizás el problema esté en los files...

¿Alguna solución que podáis aportarme? Muchas gracias...

Share this post


Link to post
Share on other sites
hace 28 minutos, Temerica dijo:

He parado de leer en 34k 

Utiliza unos files 40k con source, no inviertas mas tiempo en este proyecto de 34k.

Si solo vas a comentar para decir esta tontería, ahórrate decir nada más.

Si uso files 34k es por el simple hecho que con unos files de 40k no sirve la sura y por ende mis amigos no pueden jugar. No tengo dinero para pagar un dedicado. Y no uso hamachi, es por IP.

Share this post


Link to post
Share on other sites

Si al entrar a un mapa te saca del servidor, puede ser porque el mapa este implementado en el cliente, pero no en los sf, o que aunque estén implementados en los sf tengas mal metidas las coordenadas en el cliente, o cualquier cosa.

Share this post


Link to post
Share on other sites
hace 22 minutos, zhas77 dijo:

Si al entrar a un mapa te saca del servidor, puede ser porque el mapa este implementado en el cliente, pero no en los sf, o que aunque estén implementados en los sf tengas mal metidas las coordenadas en el cliente, o cualquier cosa.

Si, a esa conclusión llegué yo, el problema es que no se como arreglarlo xD ¿como puedo ver la relacion cliente-servidor en el tema de los mapas?

Share this post


Link to post
Share on other sites
hace 17 minutos, joaken96 dijo:

Si, a esa conclusión llegué yo, el problema es que no se como arreglarlo xD ¿como puedo ver la relacion cliente-servidor en el tema de los mapas?

Pues es simple, ve a root- atlastinfo creo que era, y la misma coordenada que pusiste en el cliente, búscala hay y te saldrá el nombre del mapa, y vas a los sf, a la parte de /usr/../../map, y buscas si esta el mapa metido.

Share this post


Link to post
Share on other sites
hace 19 minutos, joaken96 dijo:

Como miro eso?

en la raíz del cliente te aparece un archivo txt, que se crea si hay algún error, ese archivo es el sysser.

Share this post


Link to post
Share on other sites
hace 17 horas, zhas77 dijo:

Pues es simple, ve a root- atlastinfo creo que era, y la misma coordenada que pusiste en el cliente, búscala hay y te saldrá el nombre del mapa, y vas a los sf, a la parte de /usr/../../map, y buscas si esta el mapa metido.

Hola, ya lo he mirado y ambas coordenadas coinciden completamente :/

Este es el atlasinfo del root del cliente:

cliente.PNG

Y este, el game/locale/turkey/map de los files:

Files.PNG

Share this post


Link to post
Share on other sites
En 23/1/2018 a las 11:28, joaken96 dijo:

Hola, ya lo he mirado y ambas coordenadas coinciden completamente :/

Este es el atlasinfo del root del cliente:

Debes iniciar sesión para ver el contenido del enlace en esta publicación.

Y este, el game/locale/turkey/map de los files:

Debes iniciar sesión para ver el contenido del enlace en esta publicación.

Usas Files 34 o 40k?

Porque varia donde va implementado el atlasinfo

Podria estar en Locale de tu cliente

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...