Jump to content
Ryen

Problemas al reiniciar en servidor.

Recommended Posts

Hola muy buenas a todos.


 


 


 


Estoy teniendo un problema el cual  cuando reinicio el servidor me deja a Nivel 1.


 


 


Edite el source de server osea el game y puse nivel 300 y desde entonces me pasa esto y nose como solucionarlo.


 


Algun entendido del tema que me diga como poder solucionarlo u algo.


 


Saludos


Share this post


Link to post
Share on other sites
Guest Caes   
Guest Caes

Lo más seguro es que en el syserr encuentres un error con una consulta de inserción en la tabla player, prueba cambiando el tipo de dato del campo level de esa tabla de tinyint a smallint.

 

Esto pasa debido a que el valor máximo de un tinyint sin signo es de 255 y al sobrepasarlo en el juego no podrá hacer la consulta.

 

Como no dejas mucha info sobre tu estado de la db, solo estoy suponiendo que tengas ese problema, déjame el syserr para más claridad.

 

Buen día.

Share this post


Link to post
Share on other sites

Lo más seguro es que en el syserr encuentres un error con una consulta de inserción en la tabla player, prueba cambiando el tipo de dato del campo level de esa tabla de tinyint a smallint.

 

Esto pasa debido a que el valor máximo de un tinyint sin signo es de 255 y al sobrepasarlo en el juego no podrá hacer la consulta.

 

Como no dejas mucha info sobre tu estado de la db, solo estoy suponiendo que tengas ese problema, déjame el syserr para más claridad.

 

Buen día.

SYSERR: Jun 18 07:18:40.264724 :: socket_bind: bind: Address already in use
SYSERR: Jun 18 07:22:15.628844 :: Process: SEQUENCE 3cfe5000 mismatch 0xaf != 0x64 header 254
SYSERR: Jun 18 07:22:15.628881 :: Process: SEQUENCE_LOG [UNKNOWN]-------------
	[254 : 0xaf]
Jun 17 22:59:40.598096 :: SpawnMob: cannot create monster at non-exist sectree 405100 x 656600 (map 61)
Jun 17 22:59:44.598993 :: SpawnMob: cannot create monster at non-exist sectree 1077300 x 2670500 (map 198)
Jun 17 23:00:00.44148 :: SYSTEM: LOG ROTATE (2015-06-17 22)

el syser solo me tira esto..

Share this post


Link to post
Share on other sites

Ese mismo problema lo tuve y yo xD y no he encontrado solucion por ahora :(

Pues ami es loq ue dijo el ahora me toca editar el binario para que cunado entres no te salga por ejemplo nivel 40 en el select y luego cuando entras te sale el normal xD

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...