Jump to content

TheZurka

Members
  • Content Count

    53
  • Joined

  • Last visited

2 Followers

About TheZurka

  • Rank
    Aprendiz

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Buenas estoy intentando implementar nuevos bonuses de daño contra fuego, oscuridad y demás. Me tira el siguiente error, me dice que no he declarado el APPLY_ATTBONUS_EARTH por ejemplo, os dejo la imagen por aquí. [Hidden Content] Creo que peta porq supuestamente no están declaradas en ItemData. Sin embargo en ItemData.h he metido los bonuses;: [Hidden Content] La parte del server la he compilado bien, es el cliente lo que mocha. Si alguien puede echarle un vistazo se lo agredecería. Un saludo EDIT: nada arreglado, he editado el ItemData.h de UserInterface pero tenia que hacer la de GameLib
  2. Una pregunta, estoy intentando modificar el item_proto, pero no se guarda ningun cambio. He cambiado tanto los archivos del server como del cliente pero no tira. He estado mirando si hay algún otro archivo para modificar. En los files anteriores q tuve, eran las del arrival2, y las modificaba en la ruta usr/game/share/locale/germany y con eso era suficiente, después compilaba en el cliente y listo. Recuerdo que había alguna manera de saber si se modificaba por base de datos o por .txt pero no me acuerdo dónde se miraba. En estos files (akron2) los .txt están en usr/game/db. Son las únicas que he encontrado. Entiendo que si modifico ahi, tanto como en el cliente, deberían guardarse los cambios, no?
  3. Buenas todo va perfecto pero a la hora de decriptar los archivos del cliente, .akr y ,on2, el eternexus no me los reconoce, aunq tenga en settings puesto q sean de esa extensión EDIT: nada, lo he vuelto a bajar y ahora tira perfecto. Soy bobo. Saludos
  4. TheZurka

    Accesorios

    se ven guapas! +1
  5. Igual en unos días me animo a curiosear por ahí xD
  6. uff se me muy guapo! ojalá saber como va la instalación en el source xD
  7. Sisi, al final encontramos una "solución". Básicamente, hice tres pasos: Cambiar el ID de los tritones en el mob_proto (por un número que esté libre, en mi caso 4001, 4002, 4003, 4005, 4090, 4091) Cambiar el ID de las texturas en el npc_list de la carpeta root Cambiar el ID de los mobs en los group.txt y group_group.txt del servidor Como ya lo comentamos, más que una solución es un parche sucio pero funcional. Imagino que habría algun "bufo" para los que tengan el ID XXXX y que por eso pegaban como pegaban.
  8. Ahora tendré que modificar los groups de los mapas para que spawneen los "nuevos" tritones
  9. pues he hecho lo que me has dicho y ahora va dpm, pega lo que tiene que pegar, cerca de 2k. Voy a tener que hacer esto con cada uno de estos mobs... Qué pereza xD Parece ser un "parche" poco ético pero funcional, me sirve jeje
  10. Dale, pruebo y te comento a ver que tal
  11. Y con que apariencia sale el mob? Tendré que ponerle algo
  12. sobre la implementacion de mobs no tengo ni la más minima idea, tendría que documentarme un poco sobre eso xD
  13. La cosa es que el problema solo me da con estos putos tritones y los cangrejos, con los demás mobs no he tenido ningún tipo de problema. Si ya te digo, puedo modificar la salud y exp sin problema, pero el daño no
  14. Todo lo que edito por el navicat, al rebootear toma de nuevo los valores que tenía antes, no puede ser eso. NO_TXT = 0 entiendo que el no ser txt es falso, por lo que txt es true
×
×
  • Create New...